EDMessage on 10.7 Lion / IPv6

Discussion of the EDMessage and EDCommon frameworks.

EDMessage on 10.7 Lion / IPv6

Postby mjew » 23 Aug 2011, 02:53


I have been using EDMessage, and it has been working very well.
Recently, I deployed an app on Mac OS X 10.7 Lion, and EDMessage stopped working.
I believe it is because the 10.7 machine is establishing an IPv6 connection to the mail server.
The error I get it this:

8/22/11 5:46:07.104 PM MyApp: EmailDeliveryAgent: Exception in deliveryTask: NSInvalidArgumentException : Host <NSHost 0x12eab90> (null) ((
) (
)) has no IPv4 address.

Has anyone else had an issue like this?
I am going to look at the source code to see if I can fix this, but I was wondering if anyone else has solved this issue already.

- Matthew
Posts: 1
Joined: 23 Aug 2011, 02:48

Re: EDMessage on 10.7 Lion / IPv6

Postby erik » 23 Aug 2011, 21:16

Update: I double checked, there is a bunch of code in EDIPSocket that is IPv4 specific. We've even put a comment in there stating that IPv6 doesn't work yet. It was a while ago...

So, at the moment you're out of luck if you can only reach the destination via IPv6. If you decide to fix this, please let us know!

Posts: 90
Joined: 10 Oct 2009, 15:22
Location: Hamburg, Germany

Re: EDMessage on 10.7 Lion / IPv6

Postby fred » 11 Apr 2012, 10:53

Any solution for running EDMessage on Lion?

Thank you for your help!

Re: EDMessage on 10.7 Lion / IPv6

Postby woody3549 » 13 Feb 2013, 18:16


Did you get any luck with that ?

Posts: 1
Joined: 13 Feb 2013, 18:15

Return to ED Frameworks